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Overview 
 
Pivot tables in Excel are a versatile reporting tool 
that makes it easy to extract information from large 
tables of data without the use of formulas. 
 
Pivot tables are extremely user friendly in that by 
moving, or pivoting, fields of data from one location 
to another using drag and drop we can look at the 
same data in a number of different ways. 
 
This tutorial covers creating and using a pivot table 
to extract different information from one data sample. 

 

Section 1. Enter the Pivot Table Data 

1. The first step in creating a pivot table is to enter the data into a worksheet.  

When doing so, keep the following points in 
mind: 

• At least three columns of data are needed 
to create a pivot table. 

• it is important to enter data correctly. 
Errors, caused by incorrect data entry, are 
the source of many problems related to 
data management. 

• Leave no blank rows or columns when 
entering the data. This includes NOT 
leaving a blank row between the column 
headings and the first row of data. 
 

2. Next you are going to want to turn your data into a Table. To do this click on the top left most 
cell in your data and drag down to select it all. Go to the insert tab and click on Table. 
 
Converting your data into a table gives benefits that will save you time in the future when 
dealing with large amounts of data. 
 
 

Excel Pivot Tables 
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• Better formatting: The rows are banded with alternating colors making it easier for the 
eye to track along each line. 

 
• Filter drop-down menus: When you create a table, each column automatically gets filter 

drop-down menus. This allows you to quickly filter and sort your data. 

 
• Automatic formulas: If you add a formula to the right of the table, Excel will 

automatically extend the table to the right to include it. In addition, it will copy that 
formula all the way down the new column, applying the formula to the other rows in the 
table. 

 
• Table Automatically Extends: If you add data the bottom of the table, Excel will 

automatically extend the table to include the new row.  
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Section 2. Create the Pivot Table 
 
Drag select cells to highlight them. 
1. Click on the Insert tab of the Tool Bar. 
2. Click on Pivot Table to open the Create Pivot Table dialog box. 
3. By pre-selecting the data range, the Table/Range line in the dialog box should be filled in for us. 
4. Choose New Worksheet for the location of the pivot table. 

 
A blank pivot table should appear on the worksheet with 
the top left corner of the pivot table in the cell you 
selected. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
The Pivot Table Field List panel should open 
on the right-hand side of the Excel window. 
 
 
At the top of the Pivot Table Field List panel are the field 
names (column headings) from our data table. The data areas 
at the bottom of the panel are linked to the pivot table. 
 
 
 
 
 

The Pivot Table field 
name list 

The data areas are linked to 
the Pivot Table 
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Section 3. Add Data to the Pivot Table 
 
To populate the Pivot Table, you need to drag the field 
names to the bottom of the Pivot Table Field List panel and 
drop them in the data areas. 
 
The data areas in the Pivot Table Field List panel are linked 
to corresponding areas of the pivot table. As you add the 
field names to the data areas, your data is added to the pivot 
table. 
 
Depending on which fields are placed in which data area, 
different results can be obtained. 
 
 
Exercise: 
1. Drag the field names to these data areas: 

• Total Sales to the Report Filter area 
• Region to the Column Labels area 
• Sales Rep to the Row Labels area 
• Orders to the Values area 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Drag the fields to the 
appropriate areas 

The different Regions are 
how the columns are 
arranged 
 

The Rows are 
arranged by Sales 
Rep 
 

The Values within the 
table are the Sum of the # 
of Orders with totals at 
the bottom and right 
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Section 4. Filter the Pivot Table Data 
 
 

The Pivot Table has built in filtering tools that can 
be used to fine tune the results shown by the Pivot 
Table. 
 
Filtering data involves using specific criteria to limit 
what data is displayed by the Pivot Table. 
 
Exercise: 
1. Click on the down arrow next to the Column 

Labels heading in the Pivot Table to open the 
filter's drop-down list. 

2. Click on the check box next to the Select All 
option to remove the check mark from all the 
boxes in this list. 

3. Click on the check boxes next to the East and 
North options to add check marks to these 
boxes.  

4. The Pivot Table should now show only the 
order totals for the sales reps that work in the 
East and North regions. 
 
 

Section 5. Change the Pivot Table Data 

To change the results shown by the Pivot Table: 
1. Rearrange the pivot table by dragging the data fields from one data area to 

another in the Pivot Table Field List panel. 
2. Apply filtering to get the desired results.  

 
Exercise: 
1. Drag the field names to these data areas: 

• Orders to the Report Filter area 
• Sales Rep to the Column Labels area 
• Region to the Row Labels area 
• Total Sales to the Values area 

2. Click on the down arrow next to the Row Labels heading in the Pivot Table 
to open the filter's drop down list. 

3. Click on the check box next to the Select All option to remove the check 
marks from all the boxes in this list. 

4. Click on the check box next to the West option to add a check mark to this 
box. 

Use the built in filtering tools to fine tune 
the data displayed by the Pivot Table 

 

Drag the field names to 
different data areas to 
obtain different results 
from the Pivot Table 
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5. The Pivot Table should now show the total sales for only those sales reps that work in the West 
region. 

 
 

 

 

 

Section 6. Advanced Pivot Table Exercise 

1. Create a pivot table on a new worksheet 
which is based on all the cells in Excel table. 
a. Use the pivot table to display the total Tax 

Inclusive Amount for each Supplier. The 
way to do that is to put the Supplier Field 
in the Row area, and put the Tax Inclusive 
Amount in the Values Area. 

2. Rename the new sheet as: Suppliers 
3. Change the number formatting in the amount 

section of the pivot table so that it displays as 
currency. Use the pivot table feature for this 
purpose so that the new number formatting is 
retained after the pivot table is refreshed. 
(Right Click the Field->Field Settings-
>Number…->Currency) 

4. Change the column width of column B to 16. 
(Right Click the Column Header->Column 
Width) 

5. Wrap the column heading in column B so that 
it is displayed in two lines and center the text. 
(Select the Header Cell->Wrap Text in 
Toolbar) 
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6. Open the Expenses sheet and change the amount in row 16 from 
13,000 to 33,000. 

7. Open the Suppliers sheet and note the grand total at the bottom 
of the pivot table. The total did not change. This is because the 
data needs to be refreshed. Refresh the pivot table and note the 
change in the grand total. (Right Click Pivot Table->Refresh) 

8. Change the order of the supplier names in column A so that the 
suppliers are sorted in a descending order (from Z to A). (Row 
Labels Dropdown->Sort Descending) 

 

 

 

 

 

9. We will now Drill down to the source data that makes up the supplier total for the IAS 
Accountants supplier. 
a. Double click the Sum of Tax Inclusive Amount for IAS Accountants. This will open up a new 

sheet with the data for just IAS Accountants. 
b. Rename the new sheet: IAS 
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10. To see the details for a value on the Pivot 
table, 
double click it and select the field of detail to 
show 
a. Double click the IAS Accountants 
b. Select Tax Inclusive Amount and click OK 

 

 

 

 

 

 

c. Select the new amount (1,000.00) that is displayed and 
double click it  

d. Select Payment Date and click OK 

 

 

 

 

 

 

 

 

11. Open the Expenses worksheet and create another pivot table that shows an expense total (Tax  
Inclusive Amount) for each of the payment dates that are included in column I. 
  
  
  
  
  
 

You will see all the dates that 1000 
was paid to IAS Accountable 
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12. Rename the new sheet as: Payments  
 

13. Filter the pivot table so that only payment dates on or after 1 January 2012 are displayed. 

 

 

 

 

 

 

 

 

 

14. Drag Bank Codes to the Columns section of your Pivot Table to include them in separate 
columns. 

15. Adjust the column widths of all the columns that are included in the pivot table to 16. 

 

 

 

16. Click on the + to expand the data shown in the Pivot Table 
  
  
  
  
  
  
  
  
  
  
  
  
  
 

Click on the drop down to select 
Payment Date 

From here you can select what 
dates you want to include in your 
Pivot Table 

Reminder: Right click on 
the column header and 
select Column Width… 
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17. Go to the Design tab change the formatting style of the pivot table to Pivot Style Medium 20. 

 

 

18. Open the Suppliers sheet and insert a pivot table slicer based on the Account Code field.  To do 
this select the Pivot Table and click on the tab PivotTable Analyze. In there click on Insert Slicer 

 

 

 

19. In the popup select Account Code and 
click OK 

 

 

 

 

 

20. Selecting the slicer will automatically select the 
Slicer Tab in the toolbar. Change the layout of 
the slicer so that it includes three columns of 
filter buttons.  
 

21. Increase the width of the slicer so that all the filter buttons are displayed properly. 
 

22. Change the formatting style of the slicer to Slicer Style Dark 2. It’s the same as when you 
changed the style of the Pivot table, but now the styles are in the Slicer tab. 
 
 
 
 
 
 

Hover your mouse over the appropriate image in the Pivot Table Styles section of the Design tab in order to 
display a description for each of the pivot table styles 
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23. Filter the pivot table data with the 
slicer so that the supplier totals for 
only expenses that have been 
allocated to account IS-375 or 
account IS-390 are displayed in the 
pivot table. 
 
 
 
 
 
 

24. Open up a new sheet and name it Dashboard. We are going to create an interactive dashboard 
to visually display our data. 
 

25. In the Suppliers sheet right click 
on the slicer and select cut. 
Paste the slicer in the upper left 
hand corner of the Dashboard 
sheet. 
 

26. Go back to the Suppliers sheet 
and select the pivot table. In the 
Insert tab pick the horizontal bar 
chart. Right click on the bar 
chart and paste it anywhere in 
the Dashboard sheet. 
 
 

27. Repeat the steps to create a chart for the Pivot Table in the Payments sheet.  This time select a 
doughnut chart. 
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28. When you select the different options in the slicer you may notice that changes are only 
reflected in your bar chart and not in the doughnut chart. This is because the data for both 
charts are not connected to the slicer. To do this select the slicer and go to the Slicer tab. On 
the toolbar click Report Connection. 
 

29. In the popup check all boxes to make the 
connection and click OK. 
 
 

30. Now both charts will change depending on 
what you select in the slicer.  

 
Congratulations! You have just completed Microsoft Excel 2016: Basic Excel Skills. To learn more advanced Excel skills, 
please try ouran educational databases offered by the Library.  

Step 1: Go to the West Chicago Public Library’s website: wcpld.info.  

Step 2: Move your mouse over the heading “Digital Library” and click on “Research Databases and Resources”. 

Step 3: Scroll down the alphabetical list of databases and explore what we have to offer! 

Step 4: Sign in with your library card number and PIN. 


